Bienvenido(a) a Grupo Linuxero del Bajío jueves, agosto 13 2020 @ 07:58 CEST

Vulnerabilidad en el Apache

  • Autor:
  • Lecturas 1,696
Seguridad

Pues sí: el viejo y robusto Apache tiene ahora una vulnerabilidad, como hacía mucho tiempo no la tenía. Una seria vulnerabilidad. Además contamos con un exploit público.

Descripción:

El bug radica en la manera en como el Apache maneja las peticiones HTTP que usan el "modo por cachos" (chunked mode). El modo por cacho es una característica del HTTP 1.1, que permite a los clientes enviar datos como una secuencia de cachos en lugar de un bloque completo. Esta característica es útil si el cliente no sabe la longitud total de la petición al momento de comenzarla a transmitir.

El Apache simplmente no sabe detectar correctamente cachos de información codificada, y esto puede causar un buffer overflow en la pila.

Sistemas afectados:

En todas las plataformas de 64bits y en los sistemas operativos OpenBSD y Windows, el "buffer overflow" es capaz de ejecutar código arbitrario, pudiendo generar una intrusión remota.

En el resto de los sistemas operativos bajo 32bits se produce una negación de servicio (DoS).

Consecuencias:

Debido a la publicación del exploit, no es exagerado pensar de que se programen robots similares al famoso Red Code que atacaba al IIS de M$.

Acciones:

El grupo de desarrollo del Apache sacó, en menos de 24 horas una nueva versión del servidor web, junto con otras correcciones.

Por otro lado, la mayoría de las distribuciones ya ofrecen paquetes con el problema corregido.

Por lo tanto, lo único que queda para los administradores es actualizar.

¡Háganlo!